LayerSlider: Old jQuery Issue

While working on one of my elegant client’s blog I face this issue. He was using an older version of WordPress and I updated it to 3.6.1 and just after the update, what I saw, a “LayerSlider: old jQuery issue”. It is one of the strangest issues I face. Because I just update the WP version and all got finished, The site stopped working.


The error message showing LayerSlider old jQuery issue is a common issue which can arise if you are using Layer Slider and if you have changed your jQuery Version in your website or blog.
Layer Slider is generally used with WordPress Themes. And if you will upgrade or degrade your WordPress version, you can face this problem. Most of the people face this problem while updating their WordPress version to 3.6 or 3.6.1. 3.6.1 is the current version of WordPress and its necessary in terms of security that you should always use updated versions of WP core, WordPress themes and plugins. If you will use older or outdated versions, you are just leaving security loopholes for hackers. WordPress is an open source CMS and used jQuery for its own purpose and also used for functioning with either front end or back-end of blog or site.

This is a common message on the website It looks like you are using an old version (1.10.2) of the jQuery library. LayerSlider requires at least version 1.7.0 or newer. If you are using the WordPress version of LayerSlider, you can try out the “jQuery Updater” plugin from the WP plugin depository. If you don’t know what to do, you can write us a private message from our CodeCanyon profile page. We need a temporary WP admin account (or a temporary FTP account in some cases) to solve this issue.

It is totally ridiculous what this message show or you can call it a “bug” in the programming language. It said you are using an old version (1.10.2) and Layer Slider requires at least version 1.7.0. But in real scenario 1.7.0 is a lower version and 1.10.2 is a higher version. Which I think is a mistake and this message makes no sense.

But the Final conclusion is that your website does not use the supporting version of jQuery.

The real cause of this issue is Layer Slider itself. Because WordPress 3.6.1 uses 1.10.2 version of jQuery and Layer Slider is asking to update it. Which is not possible as its already on its latest version. The issue arises when Layer slider checks for jQuery version on WordPress. And it can be solved by editing jQuery files in Slider Plugin.

If you are facing the same issue here is the solution for WordPress CMS.

Follow these instructions step by step

  • 1. Download the file and Unzip it, there will be a .js file (download here)
  • 2. Now look for LayerSlider plugin, it can be under /wp-content/plugins/ or
    the /wp-content/themes/ {your-theme-name} / folder, its depend upon your configuration
    or theme you have used (because some theme are loaded with this slider)
  • 3. Upload the recently downloaded and unzipped .js file into your sliders location
    /LayerSlider/js/ folder via FTP or Cpanel whichever access you have.
    (It will ask for overwriting the file, you can overwrite it, but keep the older file
    as a backup, as I love to keep backup of everything if you don’t want to keep
    the backup just overwrite it).
  • 4. It is done and Enjoy.

Follow the steps carefully and your old jQuery issue for WordPress will be solved. Happy WordPressing

Boost Your Site With Our SEO Tips

About the Author: Arvind Panwar

Arvind is a wordpress lover, internet marketer, and content creator. He loves nature photography and is always keen to learn and try new things.

3 Thoughts to “LayerSlider: Old jQuery Issue”

  1. Hey there! I’ve been reading your site for a long time now and finally got the courage to go ahead and give you a shout out from Austin Tx! For me, this issue was fixed just by updating all the core and plugs and themes to latest. Just wanted to say Thanks & keep up the good job!

Leave a Reply

Your email address will not be published.

2  +  seven  =